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1 Introduction
This document describes the tool and the procedure for performing a migration from the Teamware Office groupware platform to Microsoft Exchange - and more specifically to Microsoft Exchange 2010.

The following can be migrated using this tool:
· Users and Groups

· Mailboxes

· Calendars - Personal Calendars and Resource Calendars
· Personal Address Books

· Mail and Calendar Permissions

· Mail forwarding rules

The migration tool has many configuration options which influence the way in which these are migrated, so it can adapt to various environments. 

For example, the migration tool can either create by itself the user accounts, or use existing users accounts from AD, migrating just their mailboxes contents.

Please note that some of the data is migrated by being read directly from Teamware Office, via its API (Teamware Link), while some of the data is exported first from Teamware Office into files and then loaded into the tool's work database prior to performing the migration. In the second category there are:

· The lists of Users, Groups and External entries

· The Personal Address Books

· The permissions for Mail and Calendar

There are two reasons for using export files in these cases: lack of functionality in the Teamware API and performance considerations.

High-level, the steps of the migration are:

1. Prepare Teamware Office and the needed export files.
2. Configure the migration tool and load the export files into the local work database.

3. Group the users to be migrated into import batches.
4. Reset the user passwords in Teamware Office.
5. (If they don't exist already in AD/Exchange) Import the users, optionally setting additional information in Exchange for them.
6. Import mailboxes permissions and calendar permissions.
7. Import groups.
8. Import mailboxes.

9. Import calendars.

10. Import personal address books.

2 The migration tool

2.1 Pre-requisites

The following need to be prepared on the machine from which the import tool will be run:

· Complete Teamware Office client, version 7.3 or higher.

· Teamware Link (the Teamware API), should be installed from the same package from which Teamware Office was installed.

· Windows Management Framework Core Package (Windows Power Shell 2.0 and WinRM 2.0): http://support.microsoft.com/kb/968930 

· (Optional) Microsoft Outlook (access Exchange mailboxes for verification), Excel (if needed to edit exported CSV files) and Access (in case you want to make direct changes to the tool's work database).

2.2 Installation

No special installation required, simply copy the provided application into the directory where it will run. It contains the following:

· The actual migration application (TWOExchangeMigration.exe) and supporting DLLS.
· config.ini: The configuration file

· two_migration.mdb: The MS Access work database. It can be stored in any directory, as its location can be specified in config.ini

2.3 Obtaining licenses

If you haven't obtained a license key already, when starting the application you will be presented with a window with the information required for generating the license key.

You can send the information through an on-line request directly from the application or by e-mail to the address indicated by the application.

Note that each license key is generated specifically for a Teamware Office and AD/Exchange server combination.

In case you do not receive the license key(s) by e-mail, please send an e-mail to proteus@proteusworld.com
2.4 Application configuration

There are an extensive number of configuration parameters which you can use to tailor the functioning of the migration tool. 

These are defined in the file config.ini, and are explained at the end of this document. Please note that modifications to config.ini become effective only after re-starting the application.

2.5 Password handling
The migration tool needs access to privileged accounts in Teamware Office and AD/Exchange. For security reasons, the passwords for these accounts are not stored in the application's normal configuration file.

Instead, when starting the application for the first time you will be prompted for the necessary login names and passwords. These will stored into a secure AES encrypted file. 

The application will ask for the following:

· Teamware admin login name and password

· Exchange admin login name and password

· Teamware default password - the password which will be set for all accounts in Teamware. More details about this later.

· Exchange default password - a default password to set in AD/Exchange for any user that the application will create.

If you need to change these passwords, delete the file config.ini.secrets, then restart the application.
2.6 Application Overview
When launched, you will be presented with the main application window, which is divided into two panels. The left panel contains the list of batches and the right panel contains two tabs, with the batch properties and controls.

The batches are basically groups of users which you define in order to make the import process easier to manage. All import operations (except for groups import) are performed at batch level.

The list of batches in the left panel will show you all currently defined batches and the number of users they contain. At the top of the list there is a generic <Unassigned users> batch, which contains all users which have not been assigned to any batch yet.

Batches are created and deleted using the two control buttons under the list of batches.

When a batch is selected in the left-side list, the Batch properties tab in the right-side panel will be loaded with the batch information, the users it contains and the status of the import operations done so far.

To perform the migration operations for the currently selected batch you need to select the Batch migration tab – which will be accessible only if the batch contains at least one user. The tab contains a number of buttons for starting various migration operations, which will be detailed later in this document.

In brief, the operations you will make with the migration tool are:
1. Load the Teamware dump files into the work database

2. Group the users into import batches and set batches properties

3. (Optional, time consuming) Check and select mail subjects to ignore.

4. Import data into Exchange, in this order: 

a. Users

b. Permissions

c. Public groups

d. Mailboxes (e-mails)

e. Calendars
f. Personal address books

Note that it is also possible to run the import of mailboxes, calendars and PABs in a fully automatic manner.

2.7 Application menu

At the top of the window there is a menu which contains:

· File: Allows you do load the needed Teamware dump files into the work database

· Groups: Control the public groups and their import

· Edit: Additional tools:

· Show all users: View all users loaded in the work database and also allows setting  Exchange logins, e-mails and passwords.
· Load nicks by AD login: The tool will lookup in AD all the Teamware login names from its database for which the Teamware mail nick is different from the Exchange alias - and it will save those aliases into the work database.

· Problem subjects: Define which mail subjects should not be imported

· Export users list: Export the list of users from local database to a tab delimited text file.

· Export groups memberships: Export to a file with all the members (users and sub-groups) for all the groups. 
· Import Exchange users list: Import Exchange login, e-mails and passwords from a tab delimited text file. This can (in fact, it should) be a file created from the "Export users lists" menu above, in which optionally additional values are set.
· Export external  entries: Export a list with the Teamware External Entries.
· Export groups: Export the list of Teamware groups.
· Reset Teamware passwords: Generate the control files which allow you reset the user passwords in the Teamware server

· Save auto-forwarding rules: Saves into a TAB-delimited file the auto-forwarding rules imported from Teamware.

· Delete all Exchange appointments: (WARNING: Use with care!) Clean all appointments from all Exchange calendars

· Unload users data/Unload all data: Delete from the work database all data loaded from the Teamware dump files.
2.7.1 Caveats and limitations
Due to either limitations in the Teamware API or due to differences in features between Teamware Office and Exchange, the following caveats and limitations exist:
· The Teamware API does not have support for recurring appointments. Therefore each occurrence of a recurring appointment will be imported as an individual appointment.
· There are two main modes for running Calendar import:

· Joined appointments: This is the standard mode, in which the same appointment appears in all attendees' calendar, and any modification to the appointment will be reflected to all attendees. 
· However, in this case each appointment is imported only when the appointment creator is migrated. In other words, you need to migrate all the users (or, more specifically, all appointments creator) to make sure that all appointments are migrated.

· The reason for this is that the Teamware API, for the same appointment, shows different IDs to each attendee. If the appointment would be migrated for each attendee, this would create a lot of duplicates - each appointment will be created multiplied by the number of attendees.
· In Exchange it is not possible to create directly accepted appointments in the attendees' calendars. Therefore the migration tool creates each appointment, dispatches the invitations to the attendees, then connects to each attendees' mailbox and accepts the invitation on behalf of that user (if, of course, the invitation was also accepted in Teamware). 

· That's why most of the time for the Calendar migration is consumed by locating and accepting the meeting invitations.

· Disjointed appointments: In this case, each attendee gets a copy of the appointment, but it is not linked to the appointments of the other attendees.
· Nevertheless, the migration tool will write in the appointment's body what was the original list of attendees.

· The main advantage of this method is that each user gets his appointments all at once, without depending on other migrations.

· Also the migration speed is 2-3 times faster.
· Resource calendars in Exchange cannot get appointments in the past. This is a default Exchange policy which cannot be changed.
· In Teamware it was possible for a meeting owner/organizer to not be in the attendees list. This is not possible in Exchange. The migration tool will do one of the following:
· If there are valid and active attendees, it will "promote" the first attendee to owner/organizer.

· Otherwise, it will add the original owner to the attendees list.

· If none of the above is possible, the account used to run the migration will become the owner/organizer.

· In either case, the name of the original owner/organizer will appended in the body of the appointment.
3 Preparations for import

3.1 Preparing Teamware Office 
Before performing the migration, the Teamware check and repair tools should be run, in order to ensure that the Teamware database is in a consistent state and that all ownerless and deleted objects are actually removed from the database.
The following tools are recommended to be used (in no particular order):

· to recover all; to resume all: general checks and repair
· toddump –f: cleanup and repair of Directory database
· tomdump –c –s: cleanup and repair of the Mail database
· tocdbchk: cleanup and repair of the Calendar database
Obviously, like with any other Teamware utilities, these should be run in the Teamware installation directory and as Teamware user. Note that some of these tools (especially tomdump and tocdbchk) can take a long time to complete.
3.2 Generating Teamware dump files

The following dump files should be generated and copied to the Exchange server where the migration tool will be run:
· toddump -S > dump_sites.txt: Sites
· toddump -R > dump_servers.txt: Servers

· toddump -V > dump_services.txt: Services
· toddump -U -u1 > dump_users.txt: Users (also contains permissions for address books and  calendars)
· toddump -U -u2 > dump_externals.txt: External entries from Directory

· toddump -C > dump_rescale.txt: Resource calendars

· toddump -A > dump_pab.txt; toddump -U -u7 >> dump_pab.txt: Personal address books (aliases and private entries respectively). Note that they are placed in the same file, since both types of object belong logically to the private address books.
· toddump -G > dump_groups.txt: Groups – both public and private groups.
· tomdump -B > dump_mailboxes.txt: Mailboxes and their permissions

There is also an additional export for the migration of annotations and green marks, see the next section for details.

3.2.1 Dump files for annotations and green marks
The Teamware API doesn't have any features for fetching mail annotations or the "green marks", so the only alternative is to load them from a dump file, store the relevant data in the local database and then use during the normal e-mail migration.

The following two commands need to be executed; the first dumps the data for received e-mails, the other for the sent e-mails:

tomdump -M -e -s | grep -e "TM_O_MAIL_RECEIVER\[2411\] ObjId" -e "TM_A_OWNER_STR_DATA\[2007\]" -e "TM_A_OWNER_INT_DATA\[2006\]" > dump_mail_annotations.txt 
tomdump -I -e -s | grep -e "TM_O_IPM\[240f\] ObjId" -e "TM_A_OWNER_STR_DATA\[2007\]" -e "TM_A_OWNER_INT_DATA\[2006\]" >> dump_mail_annotations.txt
IMPORTANT NOTE: For large mail databases, these commands can run for a very long time, from minutes to hours. It is very important to NOT interrupt them while running, otherwise you risk damaging the database.
3.2.2 Notes for multi-site configurations

For multi-site setups repeat the above procedure in each Area Master and the Enterprise Master, then copy the files into separate directories on the Exchange server, for example: dumps_em, dumps_am1 etc.

Then concatenate the files, for example by running:

copy dumps_em\dump_sites.txt + dumps_am\dump_sites.txt dump_sites.txt

copy dumps_em\dump_servers.txt + dumps_am\dump_servers.txt dump_servers.txt

copy dumps_em\dump_services.txt + dumps_am\dump_services.txt dump_services.txt

copy dumps_em\dump_users.txt + dumps_am\dump_users.txt dump_users.txt
copy dumps_em\dump_externals.txt + dumps_am\dump_externals.txt dump_externals.txt
copy dumps_em\dump_rescale.txt + dumps_am\dump_rescale.txt dump_rescale.txt

copy dumps_em\dump_pab.txt + dumps_am\dump_pab.txt dump_pab.txt

copy dumps_em\dump_groups.txt + dumps_am\dump_groups.txt dump_groups.txt
copy dumps_em\dump_mailboxes.txt + dumps_am\dump_mailboxes.txt dump_mailboxes.txt
These concatenated files will be the ones which you will load into the migration tool.
3.3 Preparing Exchange

The migration tool will need a user account for accessing Active Directory and Exchange. For permissions, the simplest approach is to use an account with Domain Admin rights. If that's not possible, for most operations it is enough for the user to be a member of Domain Users, Recipient Management, Account Operators and Server Operators. 

Give the user permissions to the Exchange Power Shell with:

Set-User -Identity <user> -RemotePowershellEnable $True

The user will additionally need Impersonation permissions (see below for details). Also useful - and required if Linked Mailboxes or Resource Mailboxes are used - is to grant it Full Access permissions to the existing and future mailboxes.

Obviously, these permissions are only needed during the migration. They can be revoked afterwards - or, easier, the account can be deleted.

Additional preparation for the Exchange server:

· Remove, or set very high, the size limits for mailboxes, messages and calendars. See: http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/c6ddc56e-da96-4ea2-98c5-4ff9223dac5b 
· Enable Circular Logging for the storage group, to avoid filling up the disk space - since the migration process will generate a large amount of log entries.
· If possible, for performance, avoid running the migration tool (with its logs and temporary files) on the same disk as the Exchange database.
· For resource calendars: 
· enable the Resource Booking Attendant, otherwise the appointments will not be properly created, and migration will be slowed down because the application will wait for confirmation/rejection messages which are never generated;
· set the Booking Window greater than 0;
· disable Forward Meeting Request to Delegates, otherwise the delegates' mailboxes will be filled with invitations;
· WinRM must be enabled and working. Follow the advice from: http://social.technet.microsoft.com/Forums/en-US/winserverManagement/thread/e5f8cfee-d4a6-4e5c-9baf-e8a8a67d9316/:
· start command prompt with Run as Administrator
· execute the commands:
reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

winrm quickconfig 
· Also to enabled WinRM you can follow these instructions: http://technet.microsoft.com/en-us/library/dd759202.aspx 
· To test from a remote machine if WinRM works, use the following command:

winrm get winrm/config -r:<server> -u:<user>

3.3.1 Impersonation

The user used by the migration tool for AD/Exchange must have impersonation access in order to be able to perform the import tasks in the mailboxes of the migrated users. Below you have a quick guide on how to perform this. The commands must be executed in the Exchange Power Shell. 

The information here is compiled from a number of sources, such as:

http://msundis.wordpress.com/2011/06/21/manage-full-access-permissions-on-mailboxes-in-exchange-2010
http://www.thesoftwaregorilla.com/2010/06/exchange-web-services-example-part-3-exchange-impersonation
First, prepare a Management Scope and a group for the users who will be allowed to do impersonation/delegation:

New-ManagementScope -Name:MigrationSecurity -RecipientRestrictionFilter {memberofgroup -eq "CN=MigrationSecurity,OU=Groups,OU=contoso.com,DC=test,DC=local"}

Assign impersonation role to the Management Scope:

New-ManagementRoleAssignment -Name:"MigrationSecurity" -Role:ApplicationImpersonation -User:"user@contoso.com" -CustomRecipientWriteScope:"MigrationSecurity"

Alternatively, the impersonation permission can be granted to the user directly:
New-ManagementRoleAssignment –Name:impersonationAssignmentName –Role:ApplicationImpersonation –User:user@contoso.com
3.3.2 Full Access permissions

These are needed when dealing with Linked Mailboxes and Resource Mailboxes, because in those cases Impersonation doesn't work. To grant Full Access permissions for existing mailboxes:

Get-Mailbox | Add-MailboxPermission -User "user@contoso.com" -AccessRights Fullaccess -InheritanceType all
For future mailboxes, you can use the graphical method described here:

http://www.thesoftwaregorilla.com/2010/06/exchange-web-services-example-part-3-exchange-impersonation
Restart the Microsoft Exchange Information Store service for the changes to take effect.

3.4 Performance considerations

For the migration tool, in the configuration file you can customize the number of maximum parallel threads to use. Before performing the migration, you can make a couple of trial runs on the actual import server to see which value gives the best overall performance for that specific server.

There are a number of things which can be done to improve the speed of the migration process:

· In IIS Manager, disable or reduce verbosity the logging for the Exchange-related virtual directories.
· In config.ini use the extended logging only when needed for debugging.

· If possible, place the directory of temporary files (temp_path) on a disk separate from the Exchange mailbox store.

· Even better, if possible, use a ramdisk for the temporary directory – see the next section for details.

· You can divide the migration on time intervals, using the settings import_date_min and import_date_max. If the application encounters a problem, you will have to re-run only the affected interval instead of the whole database.

3.4.1 Using a ramdisk for temporary files

A time consuming operation is the reading and writing of the attachment files on the disk. To improve speed, you can use a ramdisk for the temporary directory location – use the temp_path setting in config.ini. Make sure to make the ramdisk large enough, e.g. 256MB or more.
One ramdisk tool which was tested with good results is:

http://www.mydigitallife.info/2007/05/27/free-ramdisk-for-windows-vista-xp-2000-and-2003-server/
3.4.2 Performance and error counters for Mail migration

During the mail migration the application will keep track of the speed of the migration. The statistics will be written in the log after each migrated folder, showing the number of messages migrated OK, warnings and errors, as well as the speed, measured in items per minute and MB per minute.

Additionally, a separate log file with the extenstion .stat.txt, with TAB separated values, will show the results for each migrated user. This can be used both for performance tuning, as well as checking how correctly the migration was done, if there were errors etc.
3.5 Configuring application and loading dump files

The details of the configuration file will be presented in a separate appendix – but the values are pretty straight-forward.

Use the File menu to load the dump files into the application. It is important to respect the order of loading the dump files:

1. Sites
2. Servers

3. Services

4. Users

5. Resource calendars

6. External entries

7. Personal address books (PABs)

8. Groups

9. (Optional) Mailboxes permissions
10. (Optional) PAB & Calendars permissions 

11. (Optional) Auto-forwarding rules

12. (Optional) Mail annotations and "green marks"
Notes:

· The PAB permissions, calendar permissions and auto-forwarding rules are loaded from the same file as the users (the one generated with tomdump –U –u1).

· When importing Resource Calendars, this will also load automatically their permissions.

· When loading the calendars permissions, this applies only to users calendars, since the permissions for Resource Calendars have already been loaded as mentioned above - although internally Users and Resource Calendars (and their respective calendar permissions) are stored in the same place.

3.6 Defining batches
The rules by which you group users in batches are entirely up to you. One option would be to group them by the organization unit. But whatever method you decide on, it would be advisable to keep the size of the batches within manageable limits (e.g. less than 100 or even less than 50 users per batch). This way you have more granularity control over the migration process.

Note that Resource Calendars will be shown as users in the migration tool. Therefore most operations for users apply to resource calendars as well.

When you click the Select users button, a new window will open. In the left side you have a list with the users you loaded from dump files, grouped by their Teamware organization units. Also, at the top of the list, you have a special element which displays all the users.
For the sake of flexibility, the application allows you to put in a new batch a user which was previously was in another batch – even if import operations have been started for any of the batches. But this should be done only if really needed.

Clicking on any user name in the Available or Selected lists will display at the bottom of the window the properties for that user.
After you selected the users you wanted for the batch, simply click the Save button. The modifications will be applied to the batch right away.

There is also an alternative way of placing user in batches and for creating batches - see the section Setting Exchange users information for details.
3.7 Changing batches names and target OU

In the right-side pane of the main window you can enter a new name for the batch and select the target OU. If any of these are modified, the Save batch and Cancel changes become active.

The target OU designates the Organization Unit in Active Directory where the users from this batch should be imported. Every batch should have a valid target OU.

To select a target OU, click on the button next to the Target OU text box (the small button with three dots on it). This will open a window in which you can browse the current AD tree. Note that all elements are shown in the tree – including users.

When you identified the desired target, click on it in the AD tree and then click the Select button. Note that the new target is not saved in the database until you click Save batch in the main window.

3.8 Viewing users properties
The menu Edit > Show users opens a window with the list of all loaded users showing the display name (user name), the login, the e-mail address and the current assigned batch for each user.
This can be particularly useful because for many users the login name does not coincide with the e-mail address (mail nickname), which might become confusing in Exchange, as you have to use alternatively in different contexts.
3.9 Setting Exchange users information

It is possible that some of the users to already exist in AD/Exchange before doing the migration, and they might even have different login name, mail nickname or password than what is set in the migration application.

To solve this, the application allows you to define the associated AD/Exchange information for the imported accounts. You can do this also for users which don’t exist in Exchange yet but for which you want the imported information to be modified from what was in Teamware.

Specifying the Exchange login, mail nickname and passwords can be done in two ways:

1. By manually setting this information using the menu Edit > Show all users. If you double-click on a user you will get a window for editing the information. To make it easier to spot the differences, note that the Show all users window will show the Exchange information only if it is different from the Teamware information.

2. By loading the Exchange information from a file.

For the second method, use the menu Edit > Export users list to export the current list of users from the application (will also include Exchange information where specified).

The file is tab delimited and contains the following columns: user display name, Teamware login, Teamware mail nickname, Exchange login, Exchange mail nickname, Exchange password, batch, target OU.
You can open this file directly in Excel for editing, preserving the text format. You can also save it as an Excel file if you want to distribute it with formatting, and when you are finish with the modifications save it again as tab delimited text file.

The file with the updated Exchange information is imported with the menu Edit > Import Exchange users list.

After importing it, use the Show all users window to check if the information has been loaded Ok.

Note that you can specify batch names in the file, so when the file is imported the users will be placed in those respective batches. If the batch didn't exist before, it will be created.
You can specify the target OUs for the batches. It's enough to specify it only for one of the users in a batch. If for a batch there are two OUs specified, the last one in the file is considered.

Teamware passwords can also be specified in this file for some or all accounts. Where defined, these passwords will override the default Teamware password specified in config.ini.

3.10 Messages with many recipients

Messages with very large numbers of recipients are retrieved slowly through the Teamware API. To avoid slowing down the whole migration because of them, there are two options, described in the following sections.

In many cases such e-mails don’t really need to be imported. They are either periodic informative bulletins (which are better stored in Exchange public folders) or company notifications for certain events, e.g. planned network maintenance work which are not useful anymore.

3.10.1 Setting limits on recipients numbers

The first method involves using the configuration parameter import_recips_under. If it has a value greater than 0, any message with more than the number of recipients specified in this parameter will be imported without the recipients list.

If you want, you can re-import these messages on a later phase, by using the configuration parameter import_recips_over, which makes that only messages with more than the specified number of recipients will be imported, the rest will be ignored.

The stats log file has two columns corresponding to these two configuration parameters, so you can see how many messages, if any, were affected. This is useful if you specified import_recips_under in a first phase and you want to see for which users you need to run a second phase with import_recips_over.

3.10.2 Filtering out e-mail subjects

The second option relies on determining the subjects for the messages with large numbers of recipients and ignoring those messages. To do this, click the menu Edit > Problem subjects.
If you press Check mailboxes,  the application will find all the emails with over 100 users.
Note that this operation will take a while to complete, because it has to read all e-mails, from all mailboxes. It actually has to do it twice: first to find all mails with more than 100 recipients and the second time to see if there are mails with the same subjects but with less than 100 recipients.

Fortunately, this operation needs to be run only once, because the list of subjects and their respective counters is saved to the work database. 
After the list of subjects and recipients is generated, you can specify which ones of them you want to ignore – which means that any e-mail with that subject will not be imported from Teamware Office into Exchange.
Alternatively to checking all the mailboxes in Teamware, you can use the Load from file button. The input is a dump of all the e-mails details (IPMs), generated in Teamware with the command tomdump -I. Note that generating this file can take a long time on large servers and the dump file will be very large.
3.11 Resetting Teamware passwords
Unlike Exchange, Teamware Office doesn't have an "Impersonation" mode, nor does it offer features for modifying user passwords via the API, not even when connected with full administrative credentials. 
To solve this problem, the migration tool can generate special files which you can execute on the Teamware server to reset user passwords - it will use the Teamware default password you specified when you started the migration application for the first time.
IMPORTANT: By doing this, all the Teamware accounts will become accessible with the same password, which is a considerable security risk. Do not run this directly on the production Teamware Server, for the migration you should use a copy of it instead.
Make sure the password is a safe one, known by as little persons as possible. It's strongly advised to restrict network access to the Teamware server (e.g. with firewalls) so it's accessible only from the machine performing the migration.
To reset the passwords, use the menu Edit > Reset Teamware passwords. If you have a batch selected, you can choose between resetting the passwords for all Teamware users or only the passwords for the users in the current batch.

You specify the name of the file to create (for example passwd) and the application will create two files: passwd and passwd.params. Copy those files to the Teamware server, in the Teamware directory and (as Teamware user) run the command: todirmov passwd.params. This will reset the passwords for all specified users.

For safety, the application will not allow you to change the password for the ADMIN user.

In the tab-delimited file with Exchange user information (see section 3.9) you can specify Teamware passwords for individual users. Where these are set, these will override the default Teamware password.

3.11.1 Notes for multi-site configurations

The generated password file contains all the users, from all the sites. However, you will have to repeat the above operation for each Area Master and Enterprise Master, by doing the following steps:

· Modify the .params file, setting the IP address or host name for the site's Directory server

· Run todirmov as instructed above

· An .err file will be generated, containing the users which don't exist in that site. Simply delete the file and repeat the operation.

3.12 Deleting data from work database

In the Edit menu you have two Unload items which allow you to delete data from the local work database. First one delete all users data except batches, the second one delete the batches too.

4 Performing import
Preferably, you should proceed with the import tasks only after you have distributed all the users to be imported in batches. Of course, for a test system this is not mandatory.

The import tasks are executed from the Batch migration tab in the right-side panel of the main window. The only exception is the importing of the public groups, which are imported from the Groups menu.
For flexibility, the application allows you to perform the tasks in any order, with only a few obvious exceptions (e.g. you can’t import mails if the users don’t exist yet in AD).

The import tasks can be safely run multiple times without any problem, because the application will use the unique objects IDs from Teamware into Exchange in order to avoid creation of duplicates.
During the importing tasks you will see a progress window with various progress indicators. 

You also have a Cancel button which you can use to interrupt the task at any point. Of course, this will result in having only partially imported data – but the imported items themselves (e.g. mails, appointments) will be complete.
Depending on the type and number of tasks that were running at the moment of cancellation, sometimes it might take a while for all threads to gracefully finish their execution, so please be patient.

Besides importing data, the application also allows you to roll-back imports, which means deleting the imported data.
4.1 Overview of the migration panel
The Batch migration panel contains buttons for performing various migration tasks and, on the right side, a log text box where you will see the output of the performed tasks.

Briefly, the buttons are:

· Tests

· Check import users: Verify if the users in the selected batch exist in AD and if the Exchange logins work OK and if the mailboxes are activated. If the accounts exists in AD but some fields need to be updated, a list of those fields and the respective values will be produced.
· Check active mailboxes: Verify if the users mailboxes are active in Exchange. This operation is a subset of the operations in Check import users.
NOTE: In previous version, this step would have also attempted to activate the inactive mailboxes and would have updated the e-mail addresses if needed. This is not the case anymore; this operation is strictly read-only. All changes to accounts are done by the Import Users operation.
· Check Teamware logins: Verify if it is possible to login on Teamware for all users in the batch. It will also inform in the log box if any of the users don’t have the Mail or Calendar service enabled in Teamware.

· Reset AD passwords: Reset the AD passwords for the users in this batch to the password known by the migration tool – either the default password defined in config.ini or the specific Exchange passwords defined for each account (if they were set).

· Import

· Import users: Import the users into AD and activate their mailboxes. For users already in AD will also add the Teamware mail address to their addresses list, if it they are different from the Exchange e-mail addresses.
· Import mailboxes: Import all mail and mail folders.

· Import calendars
· Import PAB: Import personal address books

· Import permissions: Import the access permissions for mailboxes (in the Teamware sense), PAB and calendars.

· Import all: Perform in a single run all the import of mailboxes, calendars and PABs, ignoring as many errors as possible.

· Rollback

· Rollback users: Reverse (delete) the imported users. Will implicitly delete their resources as well.

· Rollback mailboxes: Delete all imported mails and mail folders.
· Rollback calendars: Delete all imported appointments.

· Rollback PABs: Delete all imported address books entries.

· Rollback all: Perform in a single run the rollback of mailboxes, calendars and PABs.
Under the import buttons there is also a Prompt on errors checkbox. If not checked, the application will automatically try to skip over items which generated errors. If checked, when an error occurs that can be skipped, the user will be asked if he wants to skip the item and continue processing.

Next to it there is a Use Admin Credentials checkbox. If checked (default), the application will try to use Administrator credentials for accessing the Exchange mailboxes, thus avoiding the need to reset AD passwords or to collect the passwords of all users which already exist in AD. 
4.2 Log files

During the import processes, the application will also send the output from the log box to log files. 

First, there is one main log file (log.txt) which will capture all the output.

Then for each batch and type of action individual files will also be created, containing the output only for that action. The names of these files have the format log_<batch name>_<date>_<action>.txt, where:

· batch name is the name of the batch with all non-alphanumeric characters replaced by "_"

· date is the date of the action in the format yy_mm_dd-hh_mm

· action is one of: "user", "ck_teamware", "mail", "mail_perms", "calendar", "calendar_perms" or "pab"

In the case of Import all / Rollback all operations, the "action" part will be "full_import" or "full_rollback" respectively, so all the messages will be logged in the same file.
For Mail import there is also a TAB separated values file, with the extension .stat.txt, containing the performance statistics for each users, as well as the counters with the messages imported OK or with errors.
4.3 Before importing users

Before importing users, use the Check import users. This will verify what users exist in AD and if their mailboxes are active.
For users that already exist, it will check if their e-mail and password match the ones known by the application (either the default ones from Teamware or the ones specified for individual accounts).

For users that don’t already exist, it will check that their e-mail doesn’t conflict with e-mail from other users.

4.4 Setting how mailboxes URLs are built

In config.ini you can use the settings exchange_uri_mode and exchange_uri_domain to specify how the Exchange mailboxes URLs are built. For exchange_uri_mode you can have the following values:
· 1: The URL is built from the email nick plus the domain specified in exchange_uri_domain: http://server.com/exchange/john.doe@domain.com
· 2: The URL is built only with the e-mail nick: http://server.com/exchange/john.doe
· 3: The URL is built using only the login name: http://server.com/exchange/jdoe
· 4:  Determine the URL for each user, by looking in AD and taking the e-mail which contains the authoritative domain specified in exchange_uri_domain.

· 5: Determine the URL for each user, by using their primary addresses.
For 4 and 5 please note that there will be slight speed penalty, since they require additional AD operations.
The recommended option is 4.

For individual users you can override the URLs from the menu Edit > Show All Users. Also you can do this through the Edit > Export/Import user data function.

4.5 Resetting AD passwords

If not using the Admin credentials, for users that already exist in AD and for which you don’t know the password, you can use the Reset AD passwords button to set the password to the one known by the application.

Note that you do not need to reset the AD passwords if you plan to use Admin credentials.
When this feature is used, it will act only on those users for which the default password from the migration tool doesn’t work.

However, note that once you have changed the password for a user it is not possible to revert back to the old one, so make sure that the affected users know that their password has been changed.

Don’t forget that you can use the Check import users button to verify if there are accounts for which the passwords known by the migration tool don’t work.
4.6 Importing users and mailboxes activation
When users are imported, they are created in the target OU specified for that batch. 
You can use this feature even if only some of the batch users don’t exist in AD. For the users that already exist in AD but have a different e-mail address than in Teamware, the application will add the Teamware address to that user’s list of alternative e-mail addresses. Therefore you should use the Import users function even if all users already exist in AD, just to make sure that the Teamware e-mails also exist in Exchange.
The application will use the language encoding defined in the configuration file (EN or NL) for activating the mailboxes and this will determine the folder names that will be created for those users.

IMPORTANT: For a production system you should always import ALL users doing any other import tasks. This is needed because items such as calendars or permissions might reference users from multiple batches and therefore those users should already exist.
4.7 Rollback users

You can rollback imported users at any time, which will delete all the accounts and their mailboxes.
After you do this you should use the Exchange System Manager to run the Cleanup Agent on the mailbox store and purge the deleted mailboxes.

4.8 Importing groups

In Teamware Office there are two main types of groups: 

· Public groups (system-wide)

· Private groups, which belong to individual users’ personal address books

The groups dump file loaded from Teamware contains both types of groups, but they are imported in Exchange using completely different methods.

The private groups will be imported for each batch, when the personal address books will be imported – more details in the section about PABs import.
The public groups are imported outside batches, from the Groups menu. They will be created in the Active Directory server, in the target OUs (Organization Unit) that you can specify for each group.

Public groups can be imported only as AD groups, or as distribution lists in Exchange - in which case they will get the corresponding mailboxes. However, since groups in Teamware didn't have e-mail addresses, there is no attribute that can be properly used for creating the addresses for the distributions lists, therefore the unique Teamware object ID is used for this.
First, use the menu Groups > Public groups to open the window in which you can view the groups. 

In the list of groups you can double-click on a group to open the window with the group properties. Next to the Target OU box there is a button which opens an AD browser for selecting the desired target.
You can also use the button Set default target OU to set the target for all the groups that don’t have one yet.

To perform the actual import of groups use the menu Groups > Import public groups. The import process will check if all groups have a valid target OU and if all member users exist in AD.
If not all members exist in AD, the system will show a warning with the missing users and ask for confirmation if you want to continue without those users or not.

You can safely run the groups import process repeatedly without any problem. However, note that whenever you do that the list of members for each imported group will be emptied first, so any users you have added manually to the group will be removed.
4.9 Importing permissions 
It is advisable to import mailboxes and calendars permissions before importing the actual mailboxes and calendars. This way the permissions need to be applied only to the existing default folders and when the mailboxes and calendars are imported they will inherit those permissions.
When the permissions are imported, the application will check if all trustees exist in AD and, if they don’t exist, it will ask the user if to continue with importing permissions only for the existing trustees.

The permissions system in Teamware involved allowing/disallowing permissions to specific types of items. For simplicity, these are mapped into the standard Exchange permissions sets (Publishing) Author, (Publishing) Editor, Reviewer and None.
More specifically, for mailboxes the mappings are:

· If the trustee has “Remove” permission for messages:

· Publishing Editor if the user has any of the permissions: Create folders, Change folders or Remove folders

· Editor otherwise

· If the trustee has “Insert” permissions for messages:

· Publishing Author if the user has any of the permissions: Create folders, Change folders or Remove folders

· Author otherwise

· If the trustee has “Read” or “See” permissions for messages:

· Reviewer
For calendars the mappings are:

· Publishing Editor if the trustee has the permissions: Create appointments, Confirm appointments and Change calendar or Change calendar permissions.
· Publishing Author if the trustee has the permissions: Create appointments and Modify created by self or See message text.

· Reviewer if the trustee has the permissions See message subject or Read message text.

· None (View folder) if the trustee has the permission See free time

Also, in Teamware you have the Everyone special trustee, which is mapped to the Default trustee in Exchange.

4.10 Importing RTF bodies for Mail and Calendar

Normally, only plain text bodies are migrated for Mail and Calendar. However, in Teamware you can have formatting and embedded objects (e.g. images, documents etc.) in the body, which Teamware stores in RTF format.

If desired, these can be migrated and they will appear in Exchange as RTF file attachments, called "body.rtf".

Furthermore, it is possible to define a migration threshold, meaning to only migrate the RTF body when the ratio between the RTF content and the text content is larger than a limit that you can set in config.ini. When the ratio is high for an e-mail or appointment, this means that the RTF body contains a lot of formatting or other embedded objects.

The setting is called rtf_threshold, and a value of 10 is OK in most cases.

If you want to disable RTF migration completely, just set it to 0 (default value).
IMPORTANT NOTE: Enabling RTF migration will slow down the migration, due to extra calls to Teamware and the extra temporary files written on disk. The decrease is not very big, but can be noticeable. It's best that you test on you specific system, you can use the testing stats generating during mail migration.
4.11 Importing mailboxes
Together with importing of calendars, these are the most intensive tasks of the migration process and, depending on the number of users in the batch and the number of mail items for each user, it might take up to a couple of hours for large batches.
Depending on the configuration setting mail_folders_target, the Teamware mail folders will be created either under Inbox or at the top of the mailbox.
Note that, because of the way in which the Teamware API is constructed, all imported mails will automatically be marked as “Read” in Teamware Office when the import application copies them to Exchange.
Also, all message bodies will be copied as plain-text and any formatting (e.g. colors, fonts) will be discarded. The only way to avoid this would be to fetch the message bodies in RTF and convert them to HTML – but this would require extra processing work.

During import, the mails will be read one by one from Teamware (its API is not thread-safe here), but for pushing them into Exchange the application will dispatch a number of parallel threads. That’s why is important to optimize Exchange (if possible) for multiple concurrent sessions.
If during the import the application encounters errors in fetching the messages from Teamware, then these errors will be shown in the output and logs. Where possible, the application will try to continue processing. Depending on the severity of the error, the message might be skipped from migration. The log will show after the warning message if the message was skipped or imported.

4.11.1 Unresolved mail recipients

In rare circumstances, it can happen that the Teamware API fails to resolve the e-mail address of a recipient and it will retrieve only that recipient's name. The migration tool will try to find that name among the users, personal address book entries and external entries, but they are not always present. When no e-mail address is found, the names and the respective e-mails are recorded in a log file with the termination "unresolved_recipients.txt". At the end of each batch migration a summary will be placed in the logs with all the unresolved names and how many occurrences there are for each.
4.12 Importing calendars

This operation applies, obviously, to both Users and Resource Calendars.

Importing calendars is even a more complex task than importing mailboxes, because an appointment can have multiple attendees and therefore it has to be created in a special way so that Exchange will recognize it as being the same appointment in multiple calendars.
More specifically, the application will look at all appointments in all calendars for the current batch, will identify those for which the users are organizers and will create them in the organizers’ calendars. If an appointment has more attendees, it will create and dispatch to them mails with appointment invitations. Then it will connect to each attendee Inbox, intercept the mail and create from it the appointment in the attendee calendar, after which will delete the invitation e-mail.
It is a complicated process and it has to be repeated for each appointment, but it was the only possible way to do it. If the appointments would have been created directly in each attendee calendar, then Exchange would have considered them as separate appointments and if one of the attendees or organizer would modify it, Exchange would have created new duplicate appointments in the other attendees’ calendars.
The process for calendars import has two steps:
1. (Optional) Look in all appointments and build the list with all the attendees. If not all attendees are present in AD, the user will be asked if he want to continue with importing only the existing attendees.

2. Perform the actual import of calendar appointments.

In the first step, the application will dispatch parallel threads for looking into all the Teamware calendars, after which the lists of attendees from each thread are centralized and verified.

You can choose to skip the first step to reduce the duration of the overall import process, but this also means that you will not be warned about missing attendees.

For the second step, the application will read the appointments one by one from Teamware and dispatch parallel processing threads for creating the appointments in Exchange.
In the configuration file you can specify for how many months in the past and in the future you want to import appointments. This limitation in the future will also affect the number of recurrence instances that will be created for recurring appointments.

There are different modes for handling the import of appointments with multiple attendees. See the description of the setting cale_import_mode at the end of the document for details. 
By default, these appointments are imported when their owner user is imported. This means that importing appointments for a user will create appointments in other users' calendars. 
If during the migration some appointments can't be read properly from Teamware or if there are other issues, these appointments will be logged in a file with the extension unresolved_recipients.txt, so you will at least know which appointments had problems.
4.12.1 Notes on migrating resource calendars
If the resource calendars don't already exist in the Exchange, the migration tool can create them. In Exchange these can be of two types: Room and Equipment. Using the configuration setting cale_resource_type you can specify how you want the Teamware resource calendars to be created in Exchange.
If you have resource of both types in Teamware, you can first run the import for one of the types, then change the setting, restart the tool and import the rest of the resources.

When the resource calendars exist in Exchange, the resource type does not make any difference when importing the appointments.
4.12.2 Attention points for Calendars import

There are a number of limitations for Calendars import that you need to be aware of:

1. VERY IMPORTANT! If during Calendars import the application suddenly dies with no explanation, read further. There is a critical bug in Teamware Link: if an appointment contains attendees which are Teamware users without a Calendar service, Teamware Link crashes with a StackOverflow error when trying to access the appointment. Because StackOverflow is a critical error, it cannot be handled by the normal .Net error handling routines and the migration tool process is killed as well. WORKAROUND: Enable extended logging in config.ini. After the application crashes, look in the log file to see on which appointment the error occurred. Use the Teamware Calendar client to remove the offending attendee and start the migration again.

2. Teamware Link doesn't always handle properly appointments which contain as attendees private entries (from PAB) or external entries. When trying to access such an appointment, Teamware Link will return an error code -44 (TOL_AB_ENTRY_NOT_SUPPORTED) or -125 (TOL_ENTRY_IS_FROM_OTHER_SITE - which is actually a little misleading, since sites are not relevant for external entries). In any case, since these appointments cannot be properly accessed through Teamware Link, they cannot be migrated correctly. Still the application will try to retrieve as much details as possible from the appointment and at least mark the time slot as reserved in the migrated user's calendar, adding the appointment body a note that the data was not retrieved completely from Teamware.
3. Teamware Link does not support recurring appointments. Therefore all occurrences of recurring appointments will be imported as individual appointments.

4.13 Importing PABs (personal address books)

The process of importing PABs involves actually importing the following types of objects:
· Address book entries, imported in Exchange as contacts.

· Aliases, which in Teamware are “shortcuts” to Directory users. Since Exchange does not have a similar concept, these are also imported as contacts.

· External entries. Like the Aliases, these will also be imported as contacts.

· Private groups, imported in Exchange as distribution lists.
In Teamware it is possible for private groups to contain a mix of personal address book entries and Directory users. If those Directory users have not been imported in Exchange or don’t have a matching contact in the user’s personal address book, then their information will still be added in the respective Exchange distribution lists using the information from the local database.
Important notes: Because of Exchange restrictions the following limitations apply:

· Group names in Exchange can't contain characters like: + . , & etc. All such characters will be replaced with "_"
· Distribution lists (the Exchange equivalent of Teamware private groups) can't contain contacts (private entries) if they don't have an e-mail address set. If a private group contains such entries in Teamware, when migrating to Exchange these will not appear in the corresponding distribution list (but they will still be present in the Contacts)

4.13.1 PAB groups imported as groups or categories
Private groups from PAB can be imported in Exchange as actual groups or as categories. The categories can be useful if, for example, you have very large PAB groups which are not handled well by Outlook.
One very important difference when importing as categories: if a group contains a reference to a Directory user, then the application will create in Exchange a Contact in which it will copy the details for that user. Note that the copy from the Contacts and the actual user record in Active Directory are NOT linked. Changes to the user data will NOT reflected to the corresponding Contacts.
When not importing groups as categories, you can use the option groups_create_externals in config.ini to specify if you want the aliases and external entries from private groups to be created as complete address book entries (yes) or only as items in the distribution lists (no).
4.14 Importing All

Instead of running the import for each class of objects and permissions, you can use the Import all button. This will execute in a single run all the main import operations.

Furthermore, the application will try to automatically solve any encountered errors and the entire process could go unattended. If something critical goes wrong for a specific user, the application will try to skip that user from that particular import operation and move to the next one.

Of course, all the errors will be recorded in the log and at the end of the entire process the application will list any users for which a particular import operation has failed forcing the user to be skipped.

Note that this "automatic" import process does not include importing users and checking for active mailboxes. These operations should always be performed in advance.
4.15 Saving auto-forwarding rules
Since the auto-forwarding features in Teamware and Exchange work differently - more specifically, because Exchange allows only one auto-forwarding recipient per user account - the auto-forwarding rules can't be imported directly into Exchange.

It is possible however to generate a file with the auto-forwarding rules.

First, you need to load into the migration application the auto-forwarding rules, from the menu File. It is important to do this only after you loaded the users and PAB entries, because auto-forwarding recipients in Teamware are stored as references which the application needs to resolve to actual user accounts and address book entries.

The input file is the same one used for importing users, PAB permissions and calendars permissions (the output of toddump -U -u1).

Needless to say, you need to do the loading only once, as once loaded and processed the auto-forwarding rules will be stored in the application's work database.
It is possible that some auto-forwarding rules to point to objects which don't exist anymore in Teamware (e.g. they have been deleted). Obviously, such references will be discarded by the migration tool. The application will inform you if such missing references were encountered.
After the rules are loaded and processed, they can be saved to a file from the menu Edit > Save auto-forwarding rules.
This will generate a TAB-delimited file with the following columns:

· User: The display user name of the user to whom the rule belongs to (owner)

· Teamware login: The Teamware login name of the rule owner

· Exchange login: The Exchange login name of the rule owner

· Exchange email: The Exchange e-mail alias of the rule owner

· Auto-forwarding enabled: Y/N if the user has actually enabled auto-forwarding in his Teamware account. In Teamware a user can define auto-forwarding rules and enable or disable them as needed, without having to delete or re-create the rules.

· Keep copies: Y/N if the user has requested or not to keep in his mailbox copies of the auto-forwarded messages.

· Recipient name: The free-form name of the auto-forwarding recipient. This can be a Directory name (if the recipient is a Directory user) or a PAB entry (if the recipient was created by the user in his personal address book)

· Recipient e-mail: The actual e-mail of the auto-forwarding recipient. If the recipient comes from Directory, then the Exchange address of the recipient user is shown.

· Comments: Additional comments specified by the user in his auto-forwarding rule. In Teamware, if this text was specified it was sent as an auto-forwarding notification to the sender of the auto-forwarded e-mail.

It might happened that the "Recipient e-mail" column to be empty for some of the rules. This means that the auto-forwarding rule was pointing to a PAB entry which didn't have an e-mail address defined. In such cases the user might have used the entry name ("Recipient name" column) to specify the address - but this is not mandatory.
5 Command-line parameters

It is possible to launch certain tasks directly from the command line. To do so, you must use the application TWOExchangeMigrationCmd.exe instead of TWOExchangeMigration.exe. Here are the possible parameters:

· -ux <file>: Load the CSV file with Exchange users information from the specified file.

· -lu <file>: Load the users from the specified dump file.

· -lr <file>: Load the resource calendars from the specified dump file.

· -le <file>: Load the external entries from the specified dump file.

· -lb <file>: Load the PABs from the specified dump file.

· -lg <file>: Load the groups from the specified dump file.

· -lmp <file>: Load the mailboxes permissions from the specified dump file.

· -lcp <file>: Load the PAB and calendars permissions from the specified dump file (the users file).

· -lf <file>: Load the auto-forwarding rules from the specified dump file (the users file).

· -cu <name>: Run the "Check import users" for the specified batch.

· -ca <name>: Run the "Check active mailboxes" for the specified batch.

· -ct <name>: Run the "Check Teamware logins" for the specified batch.

· -iu <name>: Run the "Import users" for the specified batch.
· -im <name>: Run the "Import mailboxes" for the specified batch.

· -imp <name>: Run the "Import permissions" for the specified batch.

· -ic <name>: Run the "Import calendars" for the specified batch.

· -ip <name>: Run the "Import PABs" for the specified batch.

· -iall <name>: Run the "Import all" for the specified batch.

6 Apendix A: Configuration file parameters

Below you have the parameters you can set in config.ini. The default configuration file provided contains also descriptions and example values for these settings.
· two_server: The IP address or hostname of the Enterprise Master Teamware server

· exchange_server: The IP address or hostname of the Exchange server

· exchange_uri: The URL for the Exchange Webservice (EWS/Exchange.asmx)
· exchange_store: Can specify the DN of an Exchange Mailbox Store in which to place the newly created accounts. If this option is not specified in config.ini, then the default store is used.

· default_target_ou: An optional setting, to be used as import target OU for all the batches which don't have a target OU specified.

· work_database: The path to the MS Access work database

· base_addr_trans: Used for specifying how the Teamware base addresses should be translated into Exchange, if any modifications are needed.
You can have multiple lines like this, one for each base address from the Teamware system - but only for those which will differ in the Exchange system. For example you could have the following lines:
base_addr_trans = tw1.company.com : company.com
base_addr_trans = tw2.company.com : company.com
base_addr_trans = tw3.company.com : ex.company.com 

· mail_folders_target: 
· inbox - (default) imported mail folders are created under Inbox
· top - imported mail folders are created in the mailbox root, on the same level as Inbox
· ad_server: The IP address or hostname of the Active Directory server

· ad_domain: The AD domain in which to place the newly created users

· exchange_uri_mode, exchange_uri_domain: How to build the Exchange base URLs. See section 4.4 Setting how mailboxes URLs are built for details.
· users_containers: When building the AD tree for "Select Target OU" the operation can take a long time and consume a lot of resources. But you can use this setting to limit the kind of AD objects into which the application will dig. The default setting is: "domain, organizationalUnit, group".
· exchange_lang: The language code to use when creating Exchange mailboxes (e.g. ‘en’, ‘nl’, 'fi' etc.).
· cale_import_mode: Controls how the Calendar import is performed. Can have one of the following values:
· 1: (Default) Import each appointment when the appointment owner is migrated. This means that, in order for all appointments to be migrated, all owner users need to be migrated.

· 3: Disjointed import. Each attendee gets a copy of the appointment, but without the list of the attendees. It is the fastest import method, but you loose the attendees lists and the links between appointments in the different attendees' calendars.

· calendar_months_past: The number of months in the past for which to import Calendar appointments. Appointments created earlier than that will not be imported. Set it to 0 if you don’t want to impose limitations in the past.

· calendar_months_future: The number of months in the future for which to import appointments.
· cale_resource_type: How to create the Teamware resource calendars in Exchange: "room" or "equipment".

· import_date_min, import_date_max: Only import mails and appointments created between these dates.

· import_recips_under: If non-zero, e-mails having more than this number of recipients will be imported without the recipients list, to save time.

· import_recips_over: If non-zero, e-mails having less than this number of recipients will not be imported. Useful if doing an import in two phases, the first phase using the import_recips_under setting.

· threads_max_exchange: The maximum number of parallel import threads to use when importing data into Exchange.

· default_base_address: The base address (domain) to use in e-mail addresses for accounts which don't have one, for example accounts created from resource calendars.
· use_admin_credentials: 1 or 0 if to use Administrator credentials by default or not.
· extended_logging: Sets the verbosity of the logging, from normal (0) to debugging (3). Note that verbose logs are much bigger and they might slow down the importing a little.
· calendar_on_first_att_only: If true, for appointments where the owner is not an attendee then the import will be done only when the first attendee is imported, to avoid duplicates when Teamware Link returns different IDs for each attendee of the same appointment.
· groups_as_categories: Control if you want to import private groups in Exchange as groups or as categories. Values: yes/no.

· groups_create_externals: Only when NOT importing PAB groups as categories. If "yes", then aliases and external entries from PAB groups will be created as full-fledged address book contacts. If "no", then those will only be created as items in the distribution lists.

· skip_activation_checks: Don’t perform the activation checks at the beginning of each migration operation.

· temp_path: Allows specifying the location of the directory for the temporary files.

· skip_mail_folders: For the first user migrated after the tool is started, skip this number of mail folders.

· skip_to_mail_folder: For the first user migrated after the tool is started, skip until this folder is encountered. Sub-folders are specified using "/" as separator, e.g. MainFolder/SubFolder1/SubFolder2 

· skip_mail_messages: For the first user migrated after the tool is started, skip this number of messages from the first migrated folder.

· rtf_threshold: The threshold for RTF migration. If 0 (default value), then RTF bodies are not migrated. Otherwise, if for a message or appointment the data ratio between the RTF body and the text body is larger than the rtf_threshold value, then RTF data is migrated and will appear in Exchange as an attachment called body.rtf.
· mail_policy_flag: Sets or clears in Exchange the flag "Automatically update e-mail address based on e-mail policy". The action is performed on user import - and you can run it repeatedly. The possible values are: 1=clear the flag; 2=set the flag; other values ignored.

· teamware_address_always_add: If set to 1, the Teamware e-mail address, with the Teamware domain, will always be added to the Exchange mailbox during user import. Should be used with mail_policy_flag=1

· teamware_address_make_primary: If 1, the Teamware e-mail address will be set as primary in Exchange. Should be used with teamware_address_always_add=1.

· teamware_address_target: If 1, set the Teamware e-mail address also in the targetAddress attribute in Active Directory. Should be used with teamware_address_always_add=1.

· extra_mail_domain: Use to specify additional e-mail addresses domains in Exchange. You can add as many extra_mail_domain lines as needed. For each line, an e-mail address will be added to the recipient in Exchange.

· mail_policy_flag: In the properties for an Exchange mailbox there is the flag Automatically update e-mail addresses based on e-mail address policy. With the setting mail_policy_flag you can configure how this flag is treated: 1=clear the flag; 2=set the flag; otherwise the flag is left unchanged.

· teamware_address_always_add: If 1, the full Teamware e-mail address, with the Teamware domain, will always be added to the Exchange mailbox during user import. When using this, you should also set mail_policy_flag=1. 
· teamware_address_make_primary: If 1, the Teamware e-mail address will be set as primary in Exchange. Use in combination with teamware_address_always_add.
· teamware_address_target: If 1, set also the Teamware address in the TargetAddress attribute of the imported users. 
· extra_mail_domain: You can specify multiple such lines. For each domain listed here, and additional e-mail address will be added to each imported uer.

· groups_create_mailbox: If 1, the public groups from Teamware will be imported as distribution lists in Exchange and will receive their respective mailboxes. Otherwise the groups are imported only as AD groups.

· groups_email_domain: When importing groups as distribution lists, this specifies the domain name to use in building the e-mail addresses for the groups. If not set, then the default AD domain will be used.
7 Appendix B: Creating and matching accounts
The migration tool can work in various situations:

· The AD/Exchange accounts don't exist. In this case the application can create all necessary accounts and mailboxes.

· The AD accounts exist, but without Exchange mailboxes. The application can create and activate the Exchange mailboxes for the accounts.

· Both the AD accounts and the Exchange mailboxes exist. The application can perform the import the Teamware data into those mailboxes 

By default the application uses the Teamware login and e-mail for creating or matching accounts in AD/Exchange. However, you can specify alternative values for these. 
IMPORTANT: If you do specify other values for the login and email, then these are the values that the migration tool will use when creating accounts in AD/Exchange or when searching for matching users, instead of the default values from Teamware.
There are three ways in which you can specify these values:
1. If the values need to be different for only a few users, you can do this directly in the application. Use the menu Edit > Show all users, then double-click a user in the list to edit its values.

2. Alternatively, you can use Edit > Export users lists. This creates a CSV file which you can edit in, for example, Excel. Then you can import the file back into the migration tool with Edit > Import Exchange users list. 
3. If the accounts already exist in AD/Exchange and the login names are the same as in Teamware, but if the e-mail addresses are different in Exchange, you can use Edit > Load nicks by AD login. This will load in the tool the e-mail addresses from Exchange (for those cases where they're different from Teamware).
The following flowchart explains how the application tool does the account matching between Teamware and AD/Exchange. The term expected address in the workflow means the manually specified Exchange address (as per above instructions) or, if it was not specified, the original Teamware address.
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8 Appendix C: Mapping of attributes for AD and Exchange

The tables below shows the main user attributes set by the migration tool in AD and Exchange. As a naming convention, we'll refer to the Teamware values by prefixing their names with tw_. For example, the e-mail address of a Teamware user is tw_email@tw_base_address. 
Note that in the migration tool you can specify, for individual users, different values for the Exchange login and e-mail. To keep things simple, we'll refer to them still as tw_login and tw_email.
	AD or Exchange attribute
	How is it set

	sAMAccountName
	tw_login

	name
	tw_username

	alias
	tw_email (Set with PS: New-Mailbox, Enable-Mailbox)

	userPrincipalName
	tw_login + AD default domain

	proxyAddresses
	By default, the primary SMTP address is composed by tw_email and the Exchange domain (with domain name translations, in they were defined in the config file).
If in the migration tool a different tw_email was specified, the original one from Teamware (but built with the Exchange domain) is also added.

If teamware_address_always_add=1, then the full original Teamware address is added (and made primary if teamware_address_make_primary=1).

Additionally, any domains specified by extra_mail_domain are also added.

	targetAddress
	Set to original Teamware e-mail, if teamware_address_target=1

	mailNickname
	tw_email

	homeMDB
	If not specified with exchange_store, then the first database is used. (Set with PS: New-Mailbox, Enable-Mailbox).

	
	


For the public groups, the following AD attributes are set:
	AD attribute
	How it is set

	sAMAccountName
	A unique string, composed by the TWO prefix and a string based on the original Teamware object ID.

	displayName
	The group name.

	groupType
	8

	mailNickName
	Same as sAMAccountName.

	mail
	Composed from sAMAccountName and the domain name to be used for the groups - either the default one from Exchange, or the one specified in the config file.

	proxyAddresses
	Same as mail.
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